Welcome to the home of the Caravel CMS
 Home  -  News  -  Download  -  Features  -  Documentation
Downloading Caravel
 
The latest release of Caravel is available at right via Sourceforge's distribution network.  Bleeding-edge Caravel development is also accessible via CVS.


Software Prerequisites

Caravel relies on the following prerequisite software:
  • OpenLDAP >= 2.2.24
  • Apache >= 1.3
  • PHP >= 4.3.8
    • Pear: XML_HTMLSax >= 2.1.2
    • Pear: DB
    • Pear: HTML_Common
    • Pear: HTML_CSS >= 1.0.0RC2 (beta)
The following software is optional but highly reccommended:
  • PostgreSQL >= 7.4 (Required for some applications; suggested (secure) backend for sessions) or MySQL (Alternative sessions backend)
  • BerkeleyDB >= 4.3 (Suggested backend for OpenLDAP)
  • Curl and Image Libraries (Required for some functionality)
The packages of this software available with your distribution are usually adequate.  Further instructions for setting up Caravel are in the Installation Guide.

Copyright © 2006 Caravel CMS
Page last modified 11/28/2007
Powered by Caravel CMS v3.4, Copyright © 2003-2014 Mennonite.net. All rights reserved.